Rabu, 06 Agustus 2008

HTTP

HTTP (HyperText Transfer Protocol) adalah protokol yang dipergunakan untuk mentransfer dokumen dalam World Wide Web (WWW). Protokol ini adalah protokol ringan, tidak berstatus dan generik yang dapat dipergunakan berbagai macam tipe dokumen.

Pengembangan HTTP dikoordinasi oleh Konsorsium World Wide Web (W3C) dan grup bekerja Internet Engineering Task Force (IETF), bekerja dalam publikasi satu seri RFC, yang paling terkenal RFC 2616, yang menjelaskan HTTP/1,1, versi HTTP yang digunakan umum sekarang ini.

HTTP adalah sebuah protokol meminta/menjawab antara client dan server. Sebuh client HTTP seperti web browser, biasanya memulai permintaan dengan membuat hubungan TCP/IP ke port tertentu di tuan rumah yang jauh (biasanya port 80). Sebuah server HTTP yang mendengarkan di port tersebut menunggu client mengirim kode permintaan (request), seperti “GET / HTTP/1.1″ (yang akan meminta halaman yang sudah ditentukan), diikuti dengan pesan MIME yang memiliki beberapa informasi kode kepala yang menjelaskan aspek dari permintaan tersebut, diikut dengan badan dari data tertentu. Beberapa kepala (header) juga bebas ditulis atau tidak, sementara lainnya (seperti tuan rumah) diperlukan oleh protokol HTTP /1,1. Begitu menerima kode permintaan (dan pesan, bila ada), server mengirim kembali kode jawaban, seperti “200 OK”, dan sebuah pesan yang diminta, atau sebuah pesan error atau pesan lainnya.

Sejarah

Protokol HTTP pertama kali dipergunakan dalam WWW pada tahun 1990. Pada saat tersebut yang dipakai adalah protokol HTTP versi 0.9. Versi 0.9 ini adalah protokol transfer dokumen secara mentah, maksudnya adalah data dokumen dikirim sesuai dengan isi dari dokumen tersebut tanpa memandang tipe dari dokumen.

Kemudian pada tahun 1996 protokol HTTP diperbaiki menjadi HTTP versi 1.0. Perubahan ini untuk mengakomodasi tipe-tipe dokumen yang hendak dikirim beserta enkoding yang dipergunakan dalam pengiriman data dokumen.

Sesuai dengan perkembangan infrastruktur internet maka pada tahun 1999 dikeluarkan HTTP versi 1.1 untuk mengakomodasi proxy, cache dan koneksi yang persisten.

Contoh Transaksi

S = Server
C = Client

C : (Inisialisasi koneksi)
C : GET /index.htm HTTP/1.1
C : Host: www.wikipedia.org
S : 200 OK
S : Mime-type: text/html
S :
S : — data dokumen –
S : (close connectioin)

Note :

* RFC= Sebuah dokumen Request for Comments (RFC) adalah salah satu dari seri dokumen infomasi dan standard internet bernomor yang diikuti secara luas oleh perangkat lunak untuk digunakan dalam jaringan, internet dan beberapa sistem operasi jaringan, mulai dari Unix, windows, dan novell netware. RFC kini diterbitkan di bawah arahan Internet Society (ISOC) dan badan-badan penyusun-standar teknisnya, seperti Internet Engineering Task Force (IETF) atau Internet Research Task Force (IRTF). Semua standar Internet dan juga TCP/IPselalu dipublikasikan dalam RFC, meskipun tidak semua RFC mendefinisikan standar Internet. Beberapa RFC bahkan hanya menawarkan informasi, percobaan/eksperimen, atau hanya informasi sejarah saja.

*Mime / RFC 1521 = Multipurpose Internet Mail Extension (disingkat menjadi MIME atau mime), merujuk kepada protokol yang luas digunakan di dalam dunia Internet yang memperluas protokol SMTP(Simple Mail Transfer Protocol) (RFC 822) untuk mengizinkan beberapa data selain teks dengan pengodean ASCII, seperti video, suara, dan berkas biner, agar dapat ditransfer melalui email tanpa harus mentranslasikan terlebih dahulu data-data tersebut ke dalam teks berformat ASCII. MIME merupakan bagian dari protokol HTTP, dan web browser dan server HTTP akan menggunakan MIME untuk menginterpretasikan berkas-berkas e-mail yang dikirimkan dan diterima.


Kalau Orang Besar Berkarya, Kita...???

Tak dapat dipungkiri bahwa kecanggihan ilmu dan teknologi yang sekarang ini sedang mengalami kemajuan yang cukup pesat. Itu merupakan hasil jerih payah para sarjana dan ilmuwan dulu yang memeras pikiran yang pada akhirnya mampu melahirkan berbagai disiplin ilmu yang sangat bermanfaat bagi kehidupan manusia sekarang ini.

Mereka itu tidak hanya berkorban waktu ataupun pikiran saja, namun lebih dari itu, tak jarang nyawapun mereka pertaruhkan.Tidak seper kita - kita yang agak males gitu klo mikir sedikit,ya nggak...???Mereka melakukan itu bukan untuk mendapatkan ketenaran ataupun pujian bahkan hadiah nobel. Tapi malah sebaliknya yang mereka dapatkan malahan cacian, ejekan dan sebagainya., apabila ilmu bertentangan dengan kebiasaan yang pada waktu itu.

Mereka bekerja keras dengan idealisme yang tinggi, ulet dan pantang putus asa dan sabar serta disiplin. Di antara mereka di dalam bekarya mempunyai keunikan-keunikan tersendiri. Untuk sekedar menambah pengetahuan mari kita telaah keunikan mereka itu.
(Kapan ya orang indonesia bisa menghapus budaya malez, pikiran cetek,& tidak disiplin).H3.......WKKKKKKKKKKKKKKKKKK......................

ISAAC NEWTON, Ditemani gemercik air dan gemercik jengkerik.




Ia dikenal banyak orang sebagai tokoh ilmu pasti dengan rumus-rumus yang telah ditemukannya, serta teori diffrensial dan integral. Bagaimana ia bekerja untuk mendapatkan semua itu ? Ia mempunyai kiat khusus, yakni menyepi menjauhkan diri dari hiruk pikuk kota yang penuh dengan berbagai aktifitas. Kiatnya itu bermula dari peristiwa berjangkitnya penyakit pes di kota di mana ia bermukim. Kala itu sudah tak terhitung orang-orang yang melarikan diri ke dusun-dusun, termasuk Newton sendiri untuk menghindari penyakit pes yang ganas itu.

Dua tahun lamanya, ia meninggalkan universitas tempat di mana ia biasa bekerja yang saban hari diliputi dengan berbagai kesibukan dan keramaian. Kini ia tinggal di sebuah desa yang terpencil sepi, sunyi dan jauh dari kesibukan kota yang keras. Ternyata di tempat itu ia tidak hanya terhindar dari wabah penyakit pes yang ganas itu, namun dalam suasana semacam itulah akhirnya ia menemukan sesuatu yang sangat mengagumkan. Dari situlah ia menyajikan ilmu differensial dan integral yang sampai saat ini masih tetap dipelajari. Ternyata ia lebih produktif dalam berkarya dengan ditemani kesepian, ocehan burung, gemerciknya air serta dedaunan dan jengkerik-jengkerik yang mengerik di malam hari.

GOETHE, Memeras Renungan di Terik Matahari.




Dia seorang pujangga yang berkebangsaan Jerman. Karya-karyanya yang berupa kata-kata mutiara telah beredar ke seluruh dunia. Dalam memeras renungannya ia mempunyai kiat khusus yang sekaligus aneh yang tak pernah dilakukan oleh kebanyakan orang.

Kita tentu merasa lumrah bila kena terik matahari merasa panas dan segera ingin berlindung. Namun lain bagi Goethe justeru dalam keadaan semacam itulah menurutnya suasana yang paling hebat untuk melahirkan karya-karyanya. Sambil berjalan di tengah terik matahari itulah tak sedikit kata-kata hikmahnya.

Dia pernah berkata “Ide-ide yang baik dalam renungan dan pikiran saya, bahkan kata-kata pilihan kebanyakan timbul ketika saya sedang berjalan-jalan. Apabila saya sedang duduk, maka pikiran tertumbuk”.

KNUT HAMSUN, Lebih senang di ruang yang berantakan




Pengarang cerita yang satu ini juga mempunyai kebiasaan yang sangat unik yang sangat jarang dilakukan oleh kebanyakan pengarang dalam memeras imajinasinya. Dalam berkarya ia memilih tempat yang kosong dan terbuka. Berantakan yang dipenuhi dengan banyak debu. Dalam ruangan semacam itu hanya dilengkapi dengan sebuah meja kecil yang sudah tua dan jelek serta kursi yang keras tak berbusa. Dalam keadaan semacam itulah karya-karya besarnya lahir yang mampu menggondol hadiah Nobel.

Pernah sekretarisnya membersihkan serta merapikan ruang kerjanya karena merasa sebel Meja tulis digantinya yang besar, kursinya diganti yang empuk serta buku-buku disusun rapi dalam almari agar tidak berantakan. Namun Hamsun masuk, langsung ia memerintahkan sektretarisnya untuk mengembalikan sebagaimana semula. Dengan suasana yang serba berantakan itulah, inspirasinya lahir sehingga berpuluh-puluh kertas telah dipenuhi dengna hasil karyanya yang sangat teratur.

KARL PROTEUS STEINMEZT, Memecah rahasia alam dengan bersampan.





Orang mengenalnya sebagai ahli ilmu alam. Dalam melahirkan karya-karyanya ia mencari teman-teman dengan keindahan alam semesta. Sengaja ia membuat kolam besar, di dalamnya dilengkapi dengan sebuah perahu sampan. Dengan bersampan enak layaknya dan santai, namun bukan seperti kebanyakan orang bersampan yang hanya untu sekedar menghilangkan keletihan dan kejenuhan otak. Dengan sampan itulah ia mencoba menggali rahasia alam. Dengan situasi semacam itulah pikiran-pikirannya mengalir di atas kertas yang telah disediakannya beserta pena yang diletakkan di sebuah papan sebagai alasanya. Begitulah ia memecahkan rahasia-rahasia alam dengan sambi bersampan.

IMMANUEL KANT. Jalan-jalan setiap jam setengah empat sore.




Adalah sebuah jalan raya yang terkenal dengan nama Filosofenlaan. Yang artinya jalan filosof-filosof, yang berada di Spanyol. Tentunya nama tersebut menyimpan cerita.

Pada waktu itu kalau kebetulan mata melihat jam tepat setengah empat sore, orang akan melihat seorang laki-laki yang berjalan-jalan di sepanjang jalan tersebut sambil memegang tongkat yang terbuat dari bambu Spanyol.

Pemandangan semacam itu senantiasa dapat disaksikan pada jam setengah empat sore. Jadi bila kebetulan jam mati, dan melihat orang itu sedang berjalan, maka tinggal memutar jarum pada pukul setengah empat. Laki-laki itu adalah Immanuel Kant, seorang ahli filsafat. Begitulah jalan yang ia tempuh dalam mengumpulkan pemikirannya, sehingga ia dijuluki dengan jam berjalan.

(Koleksi Kliping Majalah Amanah-CICA tahun 1990-an)